On 8 Jan 2002, Alexandre Julliard wrote:
If you wish, I can strip the patch down to its essential part (have separate flags for overlapped and timeout flags).
That would be better yes. Also I think they should be really separate: the type should be an enum and the flags should be in a separate variable.
This is impossible without major effort, because we are talking about the return value of the get_file_info() methods of struct object.
We'd have to change the prototype of get_file_info to take an additional (flags) argument.
Honestly, because we use at most 5 bits of that return value currently, splitting that into 2 variables seems a bit too much cleanliness to me. As long as there are clean macros to set and test the different fields, it should be ok to have type & flags in a single variable.
It would be possible to represent the return value of get_file_info with a bit field, but that wouldn't make things more beautiful to my taste.
Martin