On Monday 21 September 2009 16:46:25 Huw Davies wrote:
On Mon, Sep 21, 2009 at 03:36:21PM +0200, Marcus Meissner wrote:
On Mon, Sep 21, 2009 at 01:50:51PM +0100, Huw Davies wrote:
- if(src_type & DBTYPE_VECTOR || dst_type & DBTYPE_VECTOR) return
S_FALSE;
I think this needs brackets...
Why? It's equivalent to: if((src_type & DBTYPE_VECTOR) || (dst_type & DBTYPE_VECTOR)) return S_FALSE;
which is what I want.
Huw.
((src_type | dst_type) & DBTYPE_VECTOR) does the same but looks even more suspect to the casual programmer. Better go for clarity.