On Tue Jul 5 13:21:23 2022 +0000, Huw Davies wrote:
The `if` condition needs inverting. However, it would be better to combine this logic with the implmentation of `pulse_get_device_period()`. I'd suggest having `pulse_get_device_period()` call `static HRESULT get_device_period(EDataFlow flow, const char *pulse_name, REFERENCE_TIME *def, REFERENCE_TIME *min)` which could then also be used in `create_stream()`. You'd add `get_device_period()` when you first implement `pulse_get_device_period()` and you'd put it above `create_stream()`. Also note the second and third commits still have lowercase letters starting the commit message (and are the only two with ".drv" in the prefix).
Good catch. There's also a missing `pulse_unlock`, I'll add it.
The `get_device_period` name would clash with the `unix_funcs` enum. I could call it `_get_device_period` if that's an acceptable name.