Hi,
On 17/12/21 20:12, Francisco Casas wrote:
@@ -98,7 +98,13 @@ enum hlsl_sampler_dim HLSL_SAMPLER_DIM_2D, HLSL_SAMPLER_DIM_3D, HLSL_SAMPLER_DIM_CUBE,
- HLSL_SAMPLER_DIM_MAX = HLSL_SAMPLER_DIM_CUBE
- HLSL_SAMPLER_DIM_LAST_SAMPLER = HLSL_SAMPLER_DIM_CUBE,
- HLSL_SAMPLER_DIM_1DARRAY,
- HLSL_SAMPLER_DIM_2DARRAY,
- HLSL_SAMPLER_DIM_2DMS,
- HLSL_SAMPLER_DIM_2DMSARRAY,
- HLSL_SAMPLER_DIM_CUBEARRAY,
- HLSL_SAMPLER_DIM_MAX = HLSL_SAMPLER_DIM_CUBEARRAY, };
I would say that it doesn't make sense any more to call this enumeration hlsl_sampler_dim and its values HLSL_SAMPLER_DIM_*, given that they are used also for things different from the dimension of a sampler (e.g., the dimension of a texture). I would rather go for hlsl_dim and HLSL_DIM_*, or maybe "dimension" and "DIMENSION".
At the same time I have a vague feeling that we had already discussed this and it was decided to keep "sampler" and "SAMPLER" and I forgot about it, in which case please ignore this email.
Thanks, Giovanni.