Caibin Chen tigersoldi@gmail.com writes:
Thanks Jacek for reviewing. This time I send all the changes I have in 4 patches to make it clear that ReTxtDoc is reused between txtsrv.c and richole.c
- Suppressed Patch 97331
- Change log from try 2:
- follow COM naming convention
- move ReTxtDoc definition to header, removed
ReTxtDoc_get_ITextDocument() function
- remove COM aggregation test for ITextDocument, only test
ITextService supports querying for the interface.
dlls/riched20/Makefile.in | 1 + dlls/riched20/tests/txtsrv.c | 10 ++ dlls/riched20/txtdoc.c | 270 +++++++++++++++++++++++++++++++++++++++++++ dlls/riched20/txtdoc.h | 51 ++++++++ dlls/riched20/txtsrv.c | 6 +
Please avoid adding too many source files. In particular, if you have to add new headers and define objects there, it's a sign that things should be grouped in the same file. That's even more true for ITextDocument that already exists.