On 06/19/2011 09:31 PM, Thomas Mullaly wrote:
+#define DEFINE_EXPECT(func) \
- static BOOL expect_ ## func = FALSE, called_ ## func = FALSE
+#define SET_EXPECT(func) \
- expect_ ## func = TRUE
This seems like macro-overkill. I think a struct/table here may be a bit cleaner.
+static const CHAR szUtf16BOM[] = {'\xff','\xfe'};
Normal hex here would be more readable.