On 07/25/2018 09:35 PM, Józef Kucia wrote:
2018-07-24 14:03 GMT+02:00 Jacek Caban jacek@codeweavers.com:
+void *vkGetInstanceProcAddrWINE(VkInstance instance, const char *name)
Generally, Vulkan ICD should avoid potential clashes with Vulkan symbols. In this case, the name clash is very unlikely, but I think we should avoid exporting vk* symbols. Other exported functions are prefixed with wine_, but wine_vkGetInstanceProcAddrWINE() might be not an ideal name. I am not sure if I have better name suggestions. Perhaps, host_vkGetInstanceProcAddr(), native_vkGetInstanceProcAddr() or native_vkGetInstanceProcAddrWINE().
I don't really have preferences about this nor an idea for a better name. I sent v2 with native_* (for being explicit) and *WINE (it's nice to have that in a name), but I'm happy with any of those.
It is also a bit unfortunate that winelib apps will have to link directly to winevulkan, but going through vulkan-1.vkGetInstanceProcAddr() to get vkGetInstanceProcAddrWINE() is ugly as well.
I agree.
Thanks, Jacek