-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Am 2015-02-10 um 12:41 schrieb Martell Malone: Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement He didn't really specify this btw. The rest of the file has this format for the structs already. How do you want me to do this ?
Put them on the new line please, but don't touch existing code. In d3d code we always put them on a new line.
If you want you can later send a separate patch that changes the existing code without making any other change.
I originally had the * at the right side in the first series of patches so when he told me to change that I assumed he meant move it to the left. I will move them back.
We always have them next to the declared variable or parameter (i.e., on the right side). The reason is that the other way (that is commonly used in C++) can lead to difficult to read code:
int* pointer, not_a_pointer;
Can you give me an example of this please. Originally I had num_levels but he did say change to size. Does _countlevels suffice ? I'm not quite sure here
You consistently changed "num" to "count", as Henri asked for. But you're inconsistent re count_foo and foo_count.
No I meant to have a newline at the end of the file. It appears I made the patches worse rather than better.
Don't worry, just be patient :-) .