On Wed, Feb 27, 2019 at 02:19:16PM +0200, Gabriel Ivăncescu wrote:
Signed-off-by: Gabriel Ivăncescu gabrielopcode@gmail.com
dlls/comctl32/listbox.c | 13 +++++++++---- 1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/dlls/comctl32/listbox.c b/dlls/comctl32/listbox.c index f2d0615..46b2304 100644 --- a/dlls/comctl32/listbox.c +++ b/dlls/comctl32/listbox.c @@ -127,6 +127,11 @@ static TIMER_DIRECTION LISTBOX_Timer = LB_TIMER_NONE;
static LRESULT LISTBOX_GetItemRect( const LB_DESCR *descr, INT index, RECT *rect );
+static size_t get_item_size( const LB_DESCR *descr ) +{
- return sizeof(LB_ITEMDATA);
+}
I've sent in updated versions that rename this to get_sizeof_item() so that it doesn't get confused with a helper that returns an item's actual size.
I've also added a patch that uses the helpers for item initialization.
Huw.