From: "Gerold J. Wucherpfennig" gjwucherpfennig@gmx.net
Cool stuff Gerold. A few nits:
- if(PFCI_INT(hfci)->fNextCab==TRUE) {
It's better to avoid explicit comparison with TRUE. What if fNextCab is 10, not 1? It's still true, but it will fail the above test. Just do:
+ if(PFCI_INT(hfci)->fNextCab) {
Also, I know you're modifying existing code, but if it's not too much to ask, 2-space indent is hard to read, and the vast majority of developers do prefer 4-space indent. So if you don't mind, and we can find a solution, would be great if we can stick to 4-spaces instead.