On Thu, Jul 12, 2018 at 03:52:59PM +0800, Dmitry Timoshkov wrote:
Huw Davies huw@codeweavers.com wrote:
+DWORD WINAPI PerfCollect(LPWSTR query, LPVOID *data, LPDWORD size, LPDWORD obj_count) +{
- FIXME("%s,%p,%p,%p: stub\n", debugstr_w(query), data, size, obj_count);
A minor thing, but as I'm commenting already: could you add spaces after the commas in the format string?
Personally I don't like the spaces beween args in the relay logs because they make the log noticibly larger in size. But since this looks like a common thing in this particular file I'll change this part.
Thanks. I find it much easier to read and, hey, disk space is cheap these days ;-)
-104 stub PerfClose -105 stub PerfCollect -106 stub PerfOpen +104 stdcall PerfClose() +105 stdcall PerfCollect(wstr ptr ptr ptr) +106 stdcall PerfOpen(wstr)
On my Windows 7 box these are 111-3, so I suspect we can drop the explicit ordinals here.
I'd prefer that change go in a separate patch to avoid any potential regressions that may cause.
Difficult to see how it could cause a regression since they're currently stubs, but ok, I'll send a patch to do that.
Huw.