On Sat, 15 Jan 2022 at 00:33, Zebediah Figura zfigura@codeweavers.com wrote:
In essence, the goal is to separate the d3d12 backend. Just separate the compiler first, though, to make the diff easier to read.
NOTE TO SELF: Generate this diff with -C
Signed-off-by: Zebediah Figura zfigura@codeweavers.com
Makefile.am | 41 +- include/private/vkd3d_test.h | 19 +- tests/shader_runner.c | 862 +++++++++++++++++++++++++++++++++++ tests/shader_runner.h | 29 ++ tests/shader_runner_d3d12.c | 847 +--------------------------------- 5 files changed, 947 insertions(+), 851 deletions(-) create mode 100644 tests/shader_runner.c create mode 100644 tests/shader_runner.h
This patch introduces warnings for "make crosstest":
<vkd3d>/tests/shader_runner.c:463:38: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 4 has type ‘HRESULT’ {aka ‘long int’} [-Wformat=] ok(hr == E_FAIL, "Got unexpected hr %#x.\n", hr);