On Mon, Jun 05, 2017 at 11:06:58PM -0700, Ricardo Neri wrote:
I agree that insn-eval reads somewhat funny. I did not want to go with insn-dec.c as insn.c, in my opinion, already decodes the instruction (i.e., it finds prefixes, opcodes, ModRM, SIB and displacement bytes). In insn-eval.c I simply take those decoded parameters and evaluate them to obtain the values they contain (e.g., a specific memory location). Perhaps, insn-resolve.c could be a better name? Or maybe isnn-operands?
So actually I'm gravitating towards calling all that instruction "massaging" code with a single prefix to denote this comes from the insn decoder/handler/whatever...
I.e.,
"insn-decoder: x86: invalid register type"
or
"inat: x86: invalid register type"
or something to that effect.
I mean, If we're going to grow our own - as we do, apparently - maybe it all should be a separate entity with its proper name.
Hmm.