-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Am 2015-07-07 um 16:59 schrieb Henri Verbeet:
On 6 July 2015 at 23:47, Stefan Dösinger stefan@codeweavers.com wrote:
-void surface_translate_drawable_coords(const struct wined3d_surface *surface, HWND window, RECT *rect) +BOOL surface_clip_drawable_coords(const struct wined3d_surface *surface, HWND window,
RECT *screen_rect, RECT *other)
Can we please call these "src_rect" and "dst_rect" instead of "screen_rect" and "other"? It probably wouldn't hurt to mention "blt" somewhere in the function name either.
I think "src" and "dst" would be misleading. This function is used for blits to the frontbuffer and blits from the frontbuffer. The function doesn't care about the direction of the blit. It's always the rectangle used for accessing the frontbuffer that is clipped to the GL drawable size and location.
The same applies to the parameters of wined3d_clip_blit.
ClientToScreen(window, &offset);
...
ScreenToClient(window, &offset);
OffsetRect(rect, offset.x, offset.y);
/* Finally, translate the screen coordinate rectangle to client coordinates. */
OffsetRect(screen_rect, -offset.x, -offset.y);
That change seems pretty pointless.
Hmm right, it does seem a bit stupid :-) .