Am 08.09.2008 um 01:30 schrieb James Hawkins:
For example, the following is significantly easier to read:
ok(result == ERROR_BUFFER_TOO_SMALL || result == ERROR_INVALID_USER_BUFFER || /* win98 */ result == ERROR_INVALID_DATA, /* Vista */ "Expected ERROR_BUFFER_TOO_SMALL, got %08d\n", result);
Wouldn't it be even better to print the expected number in the same format as the actually received result?
... "Expected ERROR_BUFFER_TOO_SMALL (%08d), got %08d\n", ERROR_BUFFER_TOO_SMALL, result);
This should ease log reading as well.
MarKus