"Dimitrie O. Paun" dpaun@rogers.com wrote:
infoPtr = (TAB_INFO *)Alloc (sizeof(TAB_INFO));
- SetWindowLongA(hwnd, 0, (DWORD)infoPtr);
- SetWindowLongPtrW(hwnd, 0, (DWORD_PTR)infoPtr);
If you change it here ...
@@ -2975,7 +2952,7 @@ KillTimer(infoPtr->hwnd, TAB_HOTTRACK_TIMER);
Free (infoPtr);
- SetWindowLongA(infoPtr->hwnd, 0, 0);
- SetWindowLongW(infoPtr->hwnd, 0, 0);
... it would be better to change it here to SetWindowLongPtrW as well. I think that moving Free (infoPtr); below of SetWindowLong would be appropriate as well.
Dimi please add -p to your default diff flags, it makes the diffs much more readable.