The main conflict there is that we already use numbers to denote spec versions, for example F3DAudioInitialize8 for the XAudio 2.8 revision of X3DAudioInitialize.
If it helps, the main thing I’m trying to figure out is what name best explains that it’s the correct function to use right now, but definitely not later. Something that sticks out horribly and will make everyone want to get rid of it. A few ideas I had:
- FAudio_CommitChangesBADABI - FAudio_CommitChangesFIXME - FAudio_CommitChangesUSETHIS
The idea is that we add the above, deprecate the old one, then for ABI version 1, fix the function signature of the original and deprecate the above function for ABI version 2.
As for when those would release, I’m thinking the major version number would be enough time for everyone to adjust… I’m thinking FAudio 20.01 for version 1 and 21.01 for version 2.
-Ethan
On May 2, 2019, at 3:26 AM, Józef Kucia joseph.kucia@gmail.com wrote:
On Wed, May 1, 2019 at 9:51 PM Ethan Lee elee@codeweavers.com wrote:
Any suggestions on a new name? CommitChangesReal? For the suffix idea my plan would end up being to add the new function, deprecate the old function, then upon removing the old function, add it back with the correct signature and then deprecate the badly-named functions. This would apply to FAPOFX_CreateFX as well. I’m also up for suggestions on when to remove the deprecated functions.
If you cannot come up with a new name. I would personally go with CommitChanges2(). Other APIs use similar convention, e.g. vkCreateRenderPass2() and ID3D11DeviceContext1::CopySubresourceRegion1().