Robert Shearman rob@codeweavers.com writes:
Dmitry Timoshkov wrote:
Perhaps it would be better to prefix both a variable and lock/unlock interfaces with a module name, in this case "DEVENUM_" since they are global and externally visible.
Do we still need to worry about that crap even though we don't link directly to other DLLs anymore?
We don't have to use separate names, but it's a good idea anyway, since it makes life easier with grep, winedbg, etags, etc. In any case, please don't make internal functions look like Windows APIs; if you don't want a DEVENUM_ prefix, then name it lock_module() or something like that.
Also please change the "cLocks" name, that's really confusing ("what has a clock got to do with the ref count?").