On 4/4/22 16:48, RĂ©mi Bernon wrote:
diff --git a/dlls/winegstreamer/unixlib.h b/dlls/winegstreamer/unixlib.h index f4e2ea4966b..ca361fe54bb 100644 --- a/dlls/winegstreamer/unixlib.h +++ b/dlls/winegstreamer/unixlib.h @@ -114,10 +114,14 @@ struct wg_format enum wg_sample_flag { WG_SAMPLE_FLAG_INCOMPLETE = 1,
WG_SAMPLE_FLAG_HAS_TIMESTAMP = 2,
WG_SAMPLE_FLAG_HAS_DURATION = 4, };
struct wg_sample {
/* timestamp and duration are in 100-nanosecond units. */
LONGLONG timestamp, duration; UINT32 flags; UINT32 max_size; UINT32 size;
I don't want to bikeshed the naming and types, and I'm willing to sign off on the patch regardless, but is there a reason to diverge from wg_parser_buffer here?
I do think the PTS and duration should be unsigned, at least.