On Thu, Aug 26, 2010 at 8:11 PM, Juan Lang juan.lang@gmail.com wrote:
Hi David, I know this was committed already, but something caught my eye that I didn't understand:
- if(This->navpane.show ^ show_navpane)
Is this a cute way to write if(This->navpane.show && show_navpane) ? If so, why ^ rather than &&?
^ is bitwise-XOR, so it is more like if(This->navpane.show != show_navpane), which looks to be what he intended.
Octavian