On 2/25/19 7:38 PM, Matteo Bruni wrote:
On Sun, Feb 24, 2019 at 11:33 PM Michael Stefaniuc mstefani@winehq.org wrote:
Signed-off-by: Michael Stefaniuc mstefani@winehq.org
dlls/d3dx9_36/effect.c | 536 ++++++++++++++++++++--------------------- 1 file changed, 264 insertions(+), 272 deletions(-)
diff --git a/dlls/d3dx9_36/effect.c b/dlls/d3dx9_36/effect.c index b0dc366f6b..5bf66011ea 100644 --- a/dlls/d3dx9_36/effect.c +++ b/dlls/d3dx9_36/effect.c @@ -148,6 +148,8 @@ struct d3dx_technique struct IDirect3DStateBlock9 *saved_state; };
+#define ID3DXEffectImpl d3dx9_effect
Is it problematic (WRT your following patches, mostly) to just complete the rename right away and not introduce the define at all?
Well, it is mostly a matter of preference:
- I'm trying to minimize the amount of churn and not change the same location repeatedly. E.g. patch 2 makes use of that. The last patch that removes struct d3dx9_base_effect will remove one ID3DXEffectImpl too.
- The patch is already huge.
- Some of the helpers with a ID3DXEffectImpl parameter have inconsistent naming: "d3dx_" and "d3dx9_". Do I fix it now? Patch is too big already. So I'm leaving the issue open; for the interested reader of course </hint>.
- Oh, and I know the define is ugly but that is on purpose, just for motivation to get that removed eventually (last if I'm doing it). If you beat me to it then be my guest, I have no outstanding patch that depends on that.
bye michael