2008/12/28 Andrew Fenn andrewfenn@gmail.com:
On Sun, Dec 28, 2008 at 9:39 PM, Henri Verbeet hverbeet@gmail.com wrote:
Also, don't forget to add the prototype to the header, I noticed they're missing for all the other xinput functions as well.
I think I have added the prototypes correctly to the header file. Could you have a quick look at my patch and tell me if I am doing that right?
Other than the missing semicolon Vitaliy already mentioned, and the types being defined after their first use, I think it's useful to specify C linkage for C++ applications that might include the header.
2008/12/28 ricardo filipe ricardo_barbano@hotmail.com:
it's almost that. but it needs some changes. first you put the prototypes after the defines and typedefs, they may be needed for the prototypes. second you don't put variable names in the protypes, it should be something like:
DWORD WINAPI XInputGetState(DWORD, XINPUT_STATE*);
No, variable names are optional, but not forbidden. Usually it makes things more readable to include them.
It's a bit awkward to write "XINPUT_STATE* pState" though, since the * is part of the declarator in C, not part of the base type.