yup, the patches look good on a quick glance.
----------------------------------------
Date: Mon, 29 Dec 2008 02:30:26 +0700 From: andrewfenn@gmail.com To: hverbeet@gmail.com; wine-devel@kievinfo.com; ricardo_barbano@hotmail.com Subject: Re: xinput: Add stub XInputEnable CC: wine-devel@winehq.org
Sorry guys, that was a really bad patch I submitted much better ones to wine-patches already.
[1/2] xinput: Added prototypes to header file [2/2] xinput: Added stub for XInputEnable
2008/12/28 ricardo filipe : it's almost that. but it needs some changes. first you put the prototypes after the defines and typedefs, they may be needed for the prototypes. second you don't put variable names in the protypes, it should be something like: DWORD WINAPI XInputGetState(DWORD, XINPUT_STATE*);
No, variable names are optional, but not forbidden. Usually it makesthings more readable to include them. It's a bit awkward to write "XINPUT_STATE* pState" though, since the *is part of the declarator in C, not part of the base type.
i just meant you usually don't put the variable names, as we can see in most other headers in wine. but sure you are right ofc :) _________________________________________________________________ More than messages–check out the rest of the Windows Live™. http://www.microsoft.com/windows/windowslive/