Andrew Talbot wrote:
Eric Pouech wrote:
actually, this would be better written as: ((PIMAGE_SECTION_HEADER)(DWORD_PTR)((LPCBYTE)&((const IMAGE_NT_HEADERS*)(ntheader))->OptionalHeader + \ ((const IMAGE_NT_HEADERS*)(ntheader))->FileHeader.SizeOfOptionalHeader))
Hi Eric,
I'm not seeing too many LPCBYTEs in the code base, but I reckon const BYTE * fits the bill. Why do you prefer DWORD_PTR over ULONG_PTR?
nothing against ULONG_PTR, more likely, my proposal only has one ugly ULONG_PTR cast, while they were two