The subject line is pretty vague.
On 15 March 2016 at 22:19, Aaryaman Vasishta jem456.vasishta@gmail.com wrote:
@@ -193,8 +194,16 @@ static HRESULT WINAPI d3drm1_CreateTexture(IDirect3DRM *iface, D3DRMIMAGE *image, IDirect3DRMTexture **texture) { FIXME("iface %p, image %p, texture %p partial stub.\n", iface, image, texture);
- struct d3drm_texture *object;
- HRESULT hr;
You mix declarations and code here. The compiler should have warned about that.
- hr = d3drm_texture_create(&object);
- if (FAILED(hr))
return hr;
We would generally write that as if (FAILED(hr = d3drm_texture_create(&object))) return hr; not a big deal though.
+IDirect3DRMTexture *IDirect3DRMTexture_from_impl(struct d3drm_texture *texture) +{
- return &texture->IDirect3DRMTexture_iface;
+}
+IDirect3DRMTexture2 *IDirect3DRMTexture2_from_impl(struct d3drm_texture *texture) +{
- return &texture->IDirect3DRMTexture2_iface;
+}
+IDirect3DRMTexture3 *IDirect3DRMTexture3_from_impl(struct d3drm_texture *texture) +{
- return &texture->IDirect3DRMTexture3_iface;
+}
I don't think these are an improvement, I'd prefer them just written out.
-HRESULT Direct3DRMTexture_create(REFIID riid, IUnknown **out) +HRESULT d3drm_texture_create(struct d3drm_texture **out)
I think "texture" would be a more appropriate name than "out" here.