On 01/03/2020 23:34, Alex Henrie wrote:
On Fri, Feb 28, 2020 at 4:11 AM Serge Gautherie winehq-git_serge_180711@gautherie.fr wrote:
+/* See test_RtlGetNtProductType(), where it does not actually help */ +/* #define TEST_WITH_SEH */
In my opinion the patch would be better without these two comments.
Agreed, I'll rename the define to be more explicit instead.
+static BOOLEAN (WINAPI *pRtlGetNtProductType)(LPDWORD);
Please write DWORD * instead of LPDWORD.
Why? LPDWORD is a copy of the declaration. Moreover, it is used on other function pointers like pRtlMakeSelfRelativeSD.