Marcus Meissner wrote:
- if(nRelPos>=0) { /* if this or preceding row */
- if(nRelPos<=0) { /* if this or preceding row */ while(nRelPos<=0) {
Shouldn't that become a "do { ... } while()" then?
No, since there is a return item; after the while () loop.
I meant replacing just the while(), not the if() while().
It's mostly a matter of style though as gcc most likely will compile it to a do {} while() anyway.
Felix