On Mon, Jan 5, 2009 at 4:42 PM, Dan Kegel dank@kegel.com wrote:
Damjan wrote:
ssize_t ignored; ... ignored = write(*(This->fd), &event, sizeof(event));
You could make the ignored variable static, maybe even global.
Please don't. We don't want to ignore the errors, we want to handle them. The changes you're proposing are harmful to readability. Better to ignore the compiler warnings than to paper them over like that.
I agree in general, but you probably missed the comment above the write(): /* we don't care about the success or failure of this call */
Damjan