On Oct 4, 2015, at 12:26 PM, Aric Stewart aric@codeweavers.com wrote:
On 10/3/15 4:01 AM, Ken Thomases wrote:
On Oct 3, 2015, at 2:52 AM, Marcus Meissner marcus@jet.franken.de wrote:
diff --git a/dlls/hidclass.sys/descriptor.c b/dlls/hidclass.sys/descriptor.c index 6f8e45e..35057f1 100644 --- a/dlls/hidclass.sys/descriptor.c +++ b/dlls/hidclass.sys/descriptor.c @@ -414,7 +414,7 @@ void parse_io_feature(unsigned int bSize, int itemVal, int bTag, unsigned int *f if ((itemVal & INPUT_ARRAY) == 0) feature->isArray= TRUE; else
feature->isArray= TRUE; /* Var */
feature->isArray= FALSE; /* Var */
Hmm. First, doesn't that logic seem backward? You're now setting isArray to true only if itemVal does NOT contain INPUT_ARRAY.
How it works is that each bit is a named flag that has one meaning when on and another when off. I, admittedly confusingly, mostly named each bit after its off (0), flag meaning.
May I humbly suggest that you consider renaming those to make the code less horrible?
-Ken