"Paul TBBle Hampson" Paul.Hampson@Pobox.com wrote:
/* Make sure we haven't already got an entry for this due to substitution */
duplicate = FALSE;
LIST_FOR_EACH_ENTRY(system_font_link, &system_links, SYSTEM_LINKS, entry)
{
if(!strcmpW(system_font_link->font_name, font_link->font_name))
{
duplicate = TRUE;
break;
}
}
Font name comparison should be case insensitive. If there are other places that do that they should be fixed.
if(duplicate)
{
TRACE("\tDuplicate font_link entry, ignoring\n");
HeapFree(GetProcessHeap(), 0, font_link);
continue;
}
A '\t' at the start of a trace message doesn't improve readability.