Jacek Caban jacek@codeweavers.com writes:
@@ -84,6 +83,13 @@ static inline xmlnode *impl_from_IXMLDOMNode( IXMLDOMNode *iface ) return (xmlnode *)((char*)iface - FIELD_OFFSET(xmlnode, lpVtbl)); }
+static inline IXMLDOMNode *_IXMLDOMNode_(xmlnode *This) +{
- return (IXMLDOMNode*)&This->lpVtbl;
+}
That wrapper doesn't follow any established naming convention, and doesn't seem quite necessary. The standard way is to simply cast to the interface type. If you really want a wrapper it should be called something like IXMLDOMNode_from_impl.