Mike Hearn wrote:
Yes this looks good but for internal functions IMHO it's best to use GNU style naming, eg:
static int file_operation_delete(...) { }
SHELL_internal_function() is a better way to go, IMO. It's already the Wine convention, you can easily locate the function, and it helps make sure no two functions will be named the same thing. There's no reason to make a new convention just because you think the old one is "ugly".
Mike