Mike McCormack mike@codeweavers.com writes:
This patch demonstrates a problem with widl. This following declaration fails to parse correctly, as "async" is detected as a keyword, and disallowed as the name of a method in an interface.
[propget, id(DISPID_XMLDOM_DOCUMENT_ASYNC)] HRESULT async( [out,retval] VARIANT_BOOL *isAsync );
For the moment, I've hacked this by renaming "async" to "async_".
Yes, keyword handling is broken. You can probably work around it by adding async to the list of keywords supported by the ident: token, but it would certainly be nice to fix this properly.