On 5/30/22 03:20, RĂ©mi Bernon wrote:
dlls/mf/tests/mf.c | 3 - dlls/winegstreamer/wg_transform.c | 123 +++++++++++++++++++++++++++--- 2 files changed, 114 insertions(+), 12 deletions(-)
Looks clear and correct, just a couple of nitpicks...
- if (!(dst_info = gst_video_info_copy(&src_info)))
return false;
Any reason not to allocate dst_info on stack?
- if (!(is_caps_video(caps) ? copy_video_buffer(buffer, caps, plane_align, sample, &total_size)
: copy_buffer(buffer, caps, sample, &total_size)))
This is a little hard to read. Would you mind either using a "ret" variable, or perhaps putting the copy_video_buffer() call inside of copy_buffer()?