On 16 October 2014 17:07, Stefan Dösinger stefan@codeweavers.com wrote:
diff --git a/dlls/d3d9/tests/d3d9ex.c b/dlls/d3d9/tests/d3d9ex.c index 11fe091..34b967a 100644 --- a/dlls/d3d9/tests/d3d9ex.c +++ b/dlls/d3d9/tests/d3d9ex.c @@ -37,6 +37,7 @@ struct device_desc unsigned int width; unsigned int height; BOOL windowed;
- DWORD behavior_flags;
};
I don't like this much, I'd probably prefer "windowed" and "behavior_flags" to be merged into a single flags field and then have flags along the lines of e.g. CREATE_DEVICE_FULLSCREEN, CREATE_DEVICE_NOWINDOWCHANGES, CREATE_DEVICE_SWVP_ONLY, etc.