On Thu, 2 Jul 2020 at 19:50, Gabriel Ivăncescu gabrielopcode@gmail.com wrote:
diff --git a/include/wine/wined3d.h b/include/wine/wined3d.h index 346d1d0..cee46d3 100644 --- a/include/wine/wined3d.h +++ b/include/wine/wined3d.h @@ -905,6 +905,7 @@ enum wined3d_shader_type #define WINED3D_SWAPCHAIN_GDI_COMPATIBLE 0x00008000u #define WINED3D_SWAPCHAIN_IMPLICIT 0x00010000u #define WINED3D_SWAPCHAIN_HOOK 0x00020000u +#define WINED3D_SWAPCHAIN_TOPMOST_RESTORE 0x00040000u
Ideally WINED3D_SWAPCHAIN_TOPMOST_RESTORE would simply be merged with WINED3D_SWAPCHAIN_RESTORE_WINDOW_RECT, but the naming should at least be consistent.
So in that case I'd simply check to see if the rect is NULL or not, to restore TOPMOST, within the function that restores it, right?
No, you'd rename WINED3D_SWAPCHAIN_RESTORE_WINDOW_RECT to something like WINED3D_SWAPCHAIN_RESTORE_GEOMETRY (although it's perhaps a bit of a stretch to include the stacking order in "geometry"), and then check for that flag the same way the current patch checks for WINED3D_SWAPCHAIN_TOPMOST_RESTORE.
As for the name, how about WINED3D_SWAPCHAIN_RESTORE_WINDOW_STATE? (I'll of course send it as a separate patch)
I could live with it, but "state" is very broad.