FWIW it generally sounds good to me. I like Jacek's idea for heap_realloc(), at least on paper.
But since you wanted bikeshedding...
2018-01-21 22:05 GMT+01:00 Michael Stefaniuc mstefani@winehq.org:
diff --git a/include/wine/heap.h b/include/wine/heap.h new file mode 100644 index 0000000000..ec10db67be --- /dev/null +++ b/include/wine/heap.h @@ -0,0 +1,127 @@ +/*
- Wine heap memory allocation wrappers
- Copyright 2006 Jacek Caban for CodeWeavers
- Copyright 2013,2018 Michael Stefaniuc
Missing space after comma.
- "nofail" variants
The returned pointer is never NULL and an exception is raised in out of memory conditions.
Use only for small allocations that are not application driven.
Preferabely the allocation size should be known at compile time.
"Preferably".
/me runs