That was the worst possible defence of this patch, but I think it should be included.
What it's actually doing is removing the duplicated logic between the earlier bit of GdipDrawString, where out-of-range sizes are set to 1 << 23, and this if statement where we only apply a clipping rectangle if the sizes are out of range. We could also have added a check for e.g. scaled_rect.Width >= INT_MAX here, but I think it's better that we don't duplicate the logic.