Mike McCormack wrote:
Mike Hearn wrote:
Yes this looks good but for internal functions IMHO it's best to use GNU style naming, eg:
static int file_operation_delete(...) { }
SHELL_internal_function() is a better way to go, IMO. It's already the Wine convention, you can easily locate the function, and it helps make sure no two functions will be named the same thing. There's no reason to make a new convention just because you think the old one is "ugly".
Mike
Hmm, I see this indeed; should I rename and send again? The convension seems to be like SHELL_internetFunction(), although there also seem to be a few SHELL32_* functions I also saw a few other debugger helper functions for SHFileOperationW, named debug_shfileops_flags and debug_shfileops_action; is this a special debugger convension or should those be renamed as well ?
Joris