+typedef GLhandleARB (APIENTRY * PFNGLCREATESHADEROBJECTARBPROC)
(GLenum shaderType);
+typedef void (APIENTRY * PFNGLSHADERSOURCEARBPROC) (GLhandleARB
shaderObj, GLsizei count, const GLcharARB* *string, const GLint *length);
+typedef void (APIENTRY * PFNGLCOMPILESHADERARBPROC) (GLhandleARB shaderObj);
etc...
Those should be called PGLFN*, provided we want to stick with the naming used in the rest of the file. At the very least, it should be something else than what's used in glext.h :-) I do think that only swapping the GL and FN parts of the names isn't the best way to create a different name.