On Sat, 20 Jun 2009, Paul Vriens wrote:
if (!ci->u1.dlstLightStateType && (ci->u1.dlstLightStateType > D3DLIGHTSTATE_COLORVERTEX))
if (!ci->u1.dlstLightStateType || (ci->u1.dlstLightStateType > D3DLIGHTSTATE_COLORVERTEX))
Would:
if ((ci->u1.dlstLightStateType < D3DLIGHTSTATE_MATERIAL) || (ci->u1.dlstLightStateType > D3DLIGHTSTATE_COLORVERTEX))
be easier to read? (Matter of taste I guess).
I found the existing check (with the bug fixed ;-) easier to understand, but as you say it's a matter of taste and I do not feel strongly about it.
Gerald