Francois Gouget fgouget@free.fr writes:
It's not very clean to encapsulate malloc() & co with xmalloc(), etc, but to then call free() directly. It means if the implementation of xmalloc() is changed to call HeapAlloc() all the free() have to be changed. So encapsulate free() too.
xmalloc() is clearly a wrapper around malloc(), so there's no need to rename free(). If you want to change the allocation you should rename both to heap_alloc/heap_free or something like that.