On 14/07/17 11:58, Piotr Caban wrote:
Did you consider changing current structure instead of defining new one? I'm talking about something like: enum file_type { #if _MSVCP_VER < 140 status_unknown, file_not_found, #else file_not_found = -1, status_unknown, #endif regular_file, directory_file, ... } Thanks to it you will be able to use the same implementation of _Open_dir/_Read_dir in msvcp120 and msvcp140.
I like that idea, I'll see if I can make it work. One possible issue that pops into my mind is that we'll need both names to be available or we'll have to put msvcp120 / 140 Stat into #if statements as well. I vaguely prefer the latter option.