On 18 November 2014 21:26, Stefan Dösinger stefan@codeweavers.com wrote:
if(!EnumDisplaySettingsW(adapter->DeviceName, ENUM_REGISTRY_SETTINGS, &new_mode))
Formatting.
- else if (current_mode.dmPelsWidth == new_mode.dmPelsWidth
&& current_mode.dmPelsHeight == new_mode.dmPelsHeight
&& current_mode.dmBitsPerPel == new_mode.dmBitsPerPel
&& (current_mode.dmDisplayFrequency == new_mode.dmDisplayFrequency
|| !(new_mode.dmFields & DM_DISPLAYFREQUENCY))
&& (current_mode.u2.dmDisplayFlags == new_mode.u2.dmDisplayFlags
|| new_mode.dmFields & DM_DISPLAYFLAGS))
Shouldn't that be "!(new_mode.dmFields & DM_DISPLAYFLAGS)"?
- struct wined3d_display_mode original_mode;
- struct wined3d_display_mode original_mode, d3d_mode;
I might have just gone for "mode", but I don't care strongly.