On Mon, Sep 8, 2008 at 4:38 AM, Markus Hitter mah@jump-ing.de wrote:
Am 08.09.2008 um 01:30 schrieb James Hawkins:
For example, the following is significantly easier to read:
ok(result == ERROR_BUFFER_TOO_SMALL || result == ERROR_INVALID_USER_BUFFER || /* win98 */ result == ERROR_INVALID_DATA, /* Vista */ "Expected ERROR_BUFFER_TOO_SMALL, got %08d\n", result);
Wouldn't it be even better to print the expected number in the same format as the actually received result?
Yes, the %08d should just be %d....I just copied the first example I could find in my git log.
... "Expected ERROR_BUFFER_TOO_SMALL (%08d), got %08d\n", ERROR_BUFFER_TOO_SMALL, result);
This should ease log reading as well.
I don't see how that would help. The decimal values of error constants aren't related in a meaningful way. If you want to know the decimal value of ERROR_BUFFER_TOO_SMALL, grep include/winerror.h.