On 10.09.2017 18:16, Fabian Maurer wrote:
+typedef struct +{
- BaseFilter basefilter;
- IUnknown IUnknown_inner;
- LONG ref;
+} evr_impl;
I don't think you need a separate refcount field. Also it's not called "basefilter" in other quartz components. In fact you don't use it at all it seems in patch 6/7, and I think 7/7 is short enough to merge it with 6/7.
- ERR("(%p)->(%s,%p),not found\n", This, debugstr_guid(riid), ppv);
- return E_NOINTERFACE;
I think this is usually FIXME or WARN.
...
Style-wise, I think naming could be improved, for example "impl" part does not add anything.
I don't think you need a separate refcount field.
You mean I should use the refcount from basefilter?
Also it's not called "basefilter" in other quartz components.
Should I just call it "filter"?
Regards, Fabian Maurer