-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Hi Martell,
There are a few things in Henri's list of fixes that are still missing here:
Am 2015-02-09 um 10:28 schrieb Martell Malone:
Subject: [PATCH 2/6] dxgi: Add interface for IDXGISurface1
"include:" instead of "dxgi".
- uuid( 4ae63092-6327-4c1b-80ae-bfe12ea32b86),
You have an extra space here.
[out] HDC* hdc
HDC *hdc, or even better HDC *dc.
We avoid the Hungarian notification Microsoft once used, e.g. things like DWORD dwNumber. HDC hdc is the same kind of thing, although it's a bit of a special case.
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement .
You also have FOO* bar; vs FOO *bar; issues in this patch.
[in] IUnknown* pDevice,
[in] IUnknown* pWindow,
[in] const DXGI_SWAP_CHAIN_DESC1* pDesc,
pStuff
The same things also occur in patches 4, 5, and 6.
Patch 4:
[size_is(count_levels)] const D3D_FEATURE_LEVEL* levels,
UINT count_levels,
You are mixing count_* and *_count in patches 4, 5 and 6. For consistency's sake please make this *_count consistently.
Patch 6:
+} \ No newline at end of file
Is this intentional?
"include:" instead of "dxgi"He told me to prefix the ones involving dxgi with dxgi: and not include:
He also told me to prefix the ones involving d3d11 with d3d11: I had intended to use include but this is what his email said to do.
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement . You also have FOO* bar; vs FOO *bar; issues in this patch.
[in] IUnknown* pDevice,
[in] IUnknown* pWindow,
[in] const DXGI_SWAP_CHAIN_DESC1* pDesc,
pStuff The same things also occur in patches 4, 5, and 6
I originally had the * at the right side in the first series of patches so when he told me to change that I assumed he meant move it to the left. I will move them back.
Patch 4:
[size_is(count_levels)] const D3D_FEATURE_LEVEL* levels,
UINT count_levels,
You are mixing count_* and *_count in patches 4, 5 and 6. For consistency's sake please make this *_count consistently.
Can you give me an example of this please. Originally I had num_levels but he did say change to size. Does _countlevels suffice ? I'm not quite sure here
Patch 6:
+} \ No newline at end of file
Is this intentional? No I meant to have a newline at the end of the file. It appears I made the patches worse rather than better.
On Tue, Feb 10, 2015 at 10:53 AM, Stefan Dösinger <stefandoesinger@gmail.com
wrote:
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Hi Martell,
There are a few things in Henri's list of fixes that are still missing here:
Am 2015-02-09 um 10:28 schrieb Martell Malone:
Subject: [PATCH 2/6] dxgi: Add interface for IDXGISurface1
"include:" instead of "dxgi".
- uuid( 4ae63092-6327-4c1b-80ae-bfe12ea32b86),
You have an extra space here.
[out] HDC* hdc
HDC *hdc, or even better HDC *dc.
We avoid the Hungarian notification Microsoft once used, e.g. things like DWORD dwNumber. HDC hdc is the same kind of thing, although it's a bit of a special case.
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement .
You also have FOO* bar; vs FOO *bar; issues in this patch.
[in] IUnknown* pDevice,
[in] IUnknown* pWindow,
[in] const DXGI_SWAP_CHAIN_DESC1* pDesc,
pStuff
The same things also occur in patches 4, 5, and 6.
Patch 4:
[size_is(count_levels)] const D3D_FEATURE_LEVEL* levels,
UINT count_levels,
You are mixing count_* and *_count in patches 4, 5 and 6. For consistency's sake please make this *_count consistently.
Patch 6:
+} \ No newline at end of file
Is this intentional?
-----BEGIN PGP SIGNATURE----- Version: GnuPG v2
iQIcBAEBAgAGBQJU2eMXAAoJEN0/YqbEcdMwUmYP/A8I/1UBVqcynhIJ5qIvVTl4 sf3XQcWTmgI40JurL4D1mIaQMH+VeulQ7Jeroo9L9/WhIw1RRJ7R0jFULxZIu9tP VX5AyTVjd555jbt9DvlbmkaAicb0UuX7xSO5OelkkdwtdfuDCKnDq2+LxzXA2fXw y98vlT98meapIP5BzERMyAAyM0AkvpAMaxkBabE9w9Mj6IJUWteHQEwa2iavu0HR wBr/KotHXu/nqVD41PTYnAsyQoWeBNPBghg4RyqI42YKiOnDxuApOT9nAgewwHPA VghOW/hdlZahCZc+/Vst01pD7Sa7vS/Nuq4iDfJJVofSsXgwIdl5KT63eAOzR4Dl MefDKrEBmdTh44K/JeyCey1Rb4o6fNtPCQJV6lqXQkiHVeE/8IW8qPLectwuGPVd UtC7Fy38iR4UpDJBmPGypdZaFJzS2ZF1hO+mA/jJhOnefyL31vCeFWU+bf5ISuwo TDEGu7G/8yBpY+HKHr+++IwJlJKkEngf98ksjnyRC1PpIner05XHUDeu1PIll/FS T3aveyW5lWsyVGCyyovHLQIxfkaV6JPqR/AsuTuhDmhZu4ZQPoGLH5kpfrAhgVMA TeLGoR6RtTMOyFLob4sRI9nBR89H/UiEQ++fGbp/YXsOLnOZBJvn6y8AYh6zaeD5 6smvq4QiqsuQQS3tSC+f =CmBk -----END PGP SIGNATURE-----
"include:" instead of "dxgi"
He told me to prefix the ones involving dxgi with dxgi: and not include: He also told me to prefix the ones involving d3d11 with d3d11: I had intended to use include but this is what his email said to do. I need to clarify this before I resubmit ??
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement He didn't really specify this btw. The rest of the file has this format for the structs already. How do you want me to do this ?
On Tue, Feb 10, 2015 at 11:41 AM, Martell Malone martellmalone@gmail.com wrote:
"include:" instead of "dxgi"He told me to prefix the ones involving dxgi
with dxgi: and not include:
He also told me to prefix the ones involving d3d11 with d3d11: I had intended to use include but this is what his email said to do.
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement . You also have FOO* bar; vs FOO *bar; issues in this patch.
[in] IUnknown* pDevice,
[in] IUnknown* pWindow,
[in] const DXGI_SWAP_CHAIN_DESC1* pDesc,
pStuff The same things also occur in patches 4, 5, and 6
I originally had the * at the right side in the first series of patches so when he told me to change that I assumed he meant move it to the left. I will move them back.
Patch 4:
[size_is(count_levels)] const D3D_FEATURE_LEVEL* levels,
UINT count_levels,
You are mixing count_* and *_count in patches 4, 5 and 6. For consistency's sake please make this *_count consistently.
Can you give me an example of this please. Originally I had num_levels but he did say change to size. Does _countlevels suffice ? I'm not quite sure here
Patch 6:
+} \ No newline at end of file
Is this intentional? No I meant to have a newline at the end of the file. It appears I made the patches worse rather than better.
On Tue, Feb 10, 2015 at 10:53 AM, Stefan Dösinger < stefandoesinger@gmail.com> wrote:
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Hi Martell,
There are a few things in Henri's list of fixes that are still missing here:
Am 2015-02-09 um 10:28 schrieb Martell Malone:
Subject: [PATCH 2/6] dxgi: Add interface for IDXGISurface1
"include:" instead of "dxgi".
- uuid( 4ae63092-6327-4c1b-80ae-bfe12ea32b86),
You have an extra space here.
[out] HDC* hdc
HDC *hdc, or even better HDC *dc.
We avoid the Hungarian notification Microsoft once used, e.g. things like DWORD dwNumber. HDC hdc is the same kind of thing, although it's a bit of a special case.
Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement .
You also have FOO* bar; vs FOO *bar; issues in this patch.
[in] IUnknown* pDevice,
[in] IUnknown* pWindow,
[in] const DXGI_SWAP_CHAIN_DESC1* pDesc,
pStuff
The same things also occur in patches 4, 5, and 6.
Patch 4:
[size_is(count_levels)] const D3D_FEATURE_LEVEL* levels,
UINT count_levels,
You are mixing count_* and *_count in patches 4, 5 and 6. For consistency's sake please make this *_count consistently.
Patch 6:
+} \ No newline at end of file
Is this intentional?
-----BEGIN PGP SIGNATURE----- Version: GnuPG v2
iQIcBAEBAgAGBQJU2eMXAAoJEN0/YqbEcdMwUmYP/A8I/1UBVqcynhIJ5qIvVTl4 sf3XQcWTmgI40JurL4D1mIaQMH+VeulQ7Jeroo9L9/WhIw1RRJ7R0jFULxZIu9tP VX5AyTVjd555jbt9DvlbmkaAicb0UuX7xSO5OelkkdwtdfuDCKnDq2+LxzXA2fXw y98vlT98meapIP5BzERMyAAyM0AkvpAMaxkBabE9w9Mj6IJUWteHQEwa2iavu0HR wBr/KotHXu/nqVD41PTYnAsyQoWeBNPBghg4RyqI42YKiOnDxuApOT9nAgewwHPA VghOW/hdlZahCZc+/Vst01pD7Sa7vS/Nuq4iDfJJVofSsXgwIdl5KT63eAOzR4Dl MefDKrEBmdTh44K/JeyCey1Rb4o6fNtPCQJV6lqXQkiHVeE/8IW8qPLectwuGPVd UtC7Fy38iR4UpDJBmPGypdZaFJzS2ZF1hO+mA/jJhOnefyL31vCeFWU+bf5ISuwo TDEGu7G/8yBpY+HKHr+++IwJlJKkEngf98ksjnyRC1PpIner05XHUDeu1PIll/FS T3aveyW5lWsyVGCyyovHLQIxfkaV6JPqR/AsuTuhDmhZu4ZQPoGLH5kpfrAhgVMA TeLGoR6RtTMOyFLob4sRI9nBR89H/UiEQ++fGbp/YXsOLnOZBJvn6y8AYh6zaeD5 6smvq4QiqsuQQS3tSC+f =CmBk -----END PGP SIGNATURE-----
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Am 2015-02-10 um 12:41 schrieb Martell Malone: Patch 3:
+typedef struct DXGI_OUTDUPL_MOVE_RECT {
- POINT SourcePoint;
- RECT DestinationRect;
+} DXGI_OUTDUPL_MOVE_RECT;
{ placement He didn't really specify this btw. The rest of the file has this format for the structs already. How do you want me to do this ?
Put them on the new line please, but don't touch existing code. In d3d code we always put them on a new line.
If you want you can later send a separate patch that changes the existing code without making any other change.
I originally had the * at the right side in the first series of patches so when he told me to change that I assumed he meant move it to the left. I will move them back.
We always have them next to the declared variable or parameter (i.e., on the right side). The reason is that the other way (that is commonly used in C++) can lead to difficult to read code:
int* pointer, not_a_pointer;
Can you give me an example of this please. Originally I had num_levels but he did say change to size. Does _countlevels suffice ? I'm not quite sure here
You consistently changed "num" to "count", as Henri asked for. But you're inconsistent re count_foo and foo_count.
No I meant to have a newline at the end of the file. It appears I made the patches worse rather than better.
Don't worry, just be patient :-) .