"Clinton Stimpson" cjstimpson@utwire.net wrote:
Here's another test to add to test_GetUpdateRect(). This case doesn't uses CS_PARENTDC as suggested in bug #7360.
+static LRESULT WINAPI test_GetUpdateRect_window_procA(HWND hwnd, UINT msg, WPARAM wparam, LPARAM lparam) +{
- return DefWindowProc(hwnd, msg, wparam, lparam);
+}
You can just specify 'cls.lpfnWndProc = DefWindowProcA;' to avoid useless test_GetUpdateRect_window_procA body.
- cls.style = 0;
- cls.lpfnWndProc = test_GetUpdateRect_window_procA;
- cls.cbClsExtra = 0;
- cls.cbWndExtra = 0;
- cls.hInstance = GetModuleHandleA(0);
- cls.hIcon = 0;
- cls.hCursor = LoadCursorA(0, (LPSTR)IDC_ARROW);
- cls.hbrBackground = GetStockObject(WHITE_BRUSH);
- cls.lpszMenuName = NULL;
- cls.lpszClassName = "CSParentDCWindowClass";
Strange class name since it doesn't use CS_PARENTDC style at all.