stefan@codeweavers.com writes:
+static inline BOOL check_d3ddevicedesc_size(DWORD size) +{
- if (size == 172 || size == 204 || size == sizeof(D3DDEVICEDESC) /* 252 */) return TRUE;
- return FALSE;
+}
You should use something like FIELD_OFFSET instead of these magic constants.