2017-03-14 13:47 GMT+01:00 Paul Gofman gofmanp@gmail.com:
Signed-off-by: Paul Gofman gofmanp@gmail.com
Looks pretty good, I only have a few nitpicks here.
-static void test_effect_preshader(IDirect3DDevice9 *device) +static const D3DXVECTOR4 fvect_empty = {-9999.0f, -9999.0f, -9999.0f, -9999.0f};
I don't like the "empty" suffix much. Not sure about a better name though... Maybe fvect_filler?
+#define TEST_EFFECT_PRES_NFLOATV ARRAY_SIZE(test_effect_preshader_fconstsv)
Same as the previous patch, if you want to keep this define please call it *_COUNT. The naming in general isn't very consistent, probably better to stick to _FVECT_ and similar here and below.
if (const_updated_mask[i / TEST_EFFECT_FLOATV_BITMASK_BLOCK_SIZE]
& (1 << (i % TEST_EFFECT_FLOATV_BITMASK_BLOCK_SIZE)))
Please use 1u here.
- }
+}
Spurious empty line.